[WIP] menthe sr-tools

Discussion in 'Tool Releases' started by LucasRitter, May 29, 2020.

  1. BeautiDuwanger

    BeautiDuwanger Snow White

    Could be your ripper plugin. I have the UV issue, the models import with the x axis inverted but everything else is just fine.
     
  2. Hm maybe. Think you could give me your plugin? I can give this another shot and see what comes of it. Also what do you mean when you said "Doesn't extract real head from npcs"?
     
  3. The project is open source. If anyone wants to contribute, I’ll gladly accept their Pull Requests. I’ll return to this project, just not right now.
     
  4. BeautiDuwanger

    BeautiDuwanger Snow White

    I use blender 2.79 for this.

    You will get something like this:
    Saints Row®_ The Third™ Remastered 20_06_2020 04_16_30 p. m..png Saints Row®_ The Third™ Remastered 20_06_2020 04_16_18 p. m..png Saints Row®_ The Third™ Remastered 20_06_2020 04_16_11 p. m..png

    The game uses a generic head for every character, and another file gives it the desired shape, however ripper cant read that file, as you can see every model has the same head. There was a plugin for the OG game that somehow worked, but it doesnt with the remaster files.
     

    Attached Files:

  5. Oh that sucks. Well if it doesn't work with the remaster then, I guess I'll have to wait until someone else comes along and makes a proper ripping method then?
     
  6. BeautiDuwanger

    BeautiDuwanger Snow White

    We never even got that with the OG, so good luck :p
     
  7. Singa

    Singa Succubus Staff Member

    Tool doesn't seem to work anymore, keeps telling me to enable this thing I had to enable back when first using the tool, but it's still enabled, disabling and re-enabling doesn't fix it.

    [​IMG]
    [​IMG]
     
    Admixon likes this.
  8. I guess were in sitting ducks , but what happen to the old one, that we use to extract tweak tables from remaster?

    back then i got like several txbls character_actions, character_definitions
     
  9. Chrome 85 updated the function signatures and names, this broke the tool. Just updated it to work with Chrome 85+ again.

    To @biotear, who forked the project on GitHub:
    Just disabling the warning won't fix the file system portion. Also the srttr repo does look a lot like my code :eyes:
     
  10. Im not sure if im using this improperly or if it is not working properly for me. so i click select folder and brouse where i have vpp_pc files right? i tried both navigating to the srtt folder and chose the cache folder as well as separating the file i wanted to extract to a different folder and both resulted in "Selected file is not a directory. Please try again" could you please explain what am i doing wrong? thanks.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice