My Steelport emulator

Fantastic! I like being able to start a new game in a costume. It reverts to the Pleasant Day outfit when in the Leave it to the Saints segment. Do you know of a way to be in costume during that segment? If not, that's fine. I love the mod. Thanks for making it.
view
 

Attachments

  • Saints Row IV Screenshot 2021.01.27 - 09.20.49.15.png
    Saints Row IV Screenshot 2021.01.27 - 09.20.49.15.png
    1.4 MB · Views: 29
I run into an issue. Running MySteelportEmulator.exe results in the following:

Unhandled Exception: System.Net.Sockets.SocketException : Access to the software channel in violation of access permissions
at the following location: System.Net.Sockets.Socket.DoBind(EndPoint endPointSnapshot, SocketAddress socketAddress)
at the following location: System.Net.Sockets.Socket.Bind(EndPoint localEP)
at the following location: SaintsRowAPI.ConnectionListener..ctor()
at the following location: SaintsRowAPI.ConsoleHost.Program.Main(String[] args)

This happens with both v1.0 AND v1.1. I also tried to compile it from source just to see what happens, but I have no idea how to do it. It's a bit different from what I learn in school...
View attachment 27216

I had to disable my VM software services and network adapters. I've got both VMware and VBox installed.


Edit:

Socket error aside (solved), the GOG fix solved my Steam/SR3 offline issue. I don't currently have an internet connection at home, therefore I'm usually gaming offline.
 

Attachments

  • sr3-mysteelportemulator.png
    sr3-mysteelportemulator.png
    1,023.7 KB · Views: 18
Last edited by a moderator:
Top