My Steelport emulator

I followed the instructions but its not working for me. The emulator just sits at Ready for connections. I have the line in the host, identical to all the screenshots. I have only one host file, and I've restarted the the game, steam, and my pc several times. even tried running the emulator after the game was already started like id seen work for someone else. Even downloaded sriv to see if it worked there but still no.

Edit: I undid everything and started over and it works now, I assume I did something wrong the first time but still no idea where
Thank you for the achievement
Last edited:
I don't know how to make a file

Can someone help me?

I don't have my existing files. Where can I find them

Er. It should definitely be there. Make sure you've changed the dropdown to all files.

Nope. GOG version has all of the community features turned off. It may be possible to get them working again though. It's something I want to investigate.
Where can I download my file for MySteelportEmulator 1.1.7.z
I have sr3 on pc. message shows connected to my steelport emulator but community features not working. It says its not connect to the server isnot available. Help me how to fix it please.
Last edited:
Guys please help me. İ cant find the hosts file. lmhosts is not the same as hosts. Please help
Hello, impossible for me to do.
When I unzip the MySteelportEmulator-1.1 file, winrar opens a window showing me errors.
So when I click on MySteelportEmulator.exe it writes to me: This application cannot be opened on your PC!
Do you have a solution ?
I'm on Windows 10
I really need help, that's the only thing I'm missing
Thanks in advance