1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Minimaul's Saints Row 2, Saints Row: The Third, Saints Row IV and Gat Out Of Hell tools

Discussion in 'Tool Releases' started by Minimaul, Aug 19, 2013.

  1. You may be already aware of this but the BuildPackFile and EditPackFile functions are not working with SRTT VPP_PC files (r130 I think, might want to add a -v version switch).


    ThomasJepp.SaintsRow.BuildPackfile.exe srtt "soundboot.vpp_pc" "Temp"

    Building Temp using data from soundboot.vpp_pc.

    Unhandled Exception: System.NotImplementedException: The method or operation is not implemented.
    at ThomasJepp.SaintsRow.BuildPackfile.Program.Main(String[] args)
     
  2. I'm having an issue cloning some hats with version 121 of the CustomizationItemClone tool. It effects the following hats/masks (that I've tried): Safeword Special, High Noon, Witch Hat, Zinyak Mask, Apocalyptic Goggles, and Santa Hat. Some hats I've tried that had no issues: Elf Hat, Murderbrawl Mask, Skeleton Mask, Country Straw Hat, Killbane.

    On the Safeword Special and the High Noon hat it changes the secondary color to 0/0/0 RGB that is uncolorable. On the other hats/masks it makes things glow oddly. These two pictures show items that I cloned and uploaded without making any changes.
    [​IMG]
    [​IMG]
    A workaround is opening the original file, copying the contents of the .str2_pc, renaming them to the cloned item names, and then repacking them.
     
    Last edited: Apr 15, 2017
  3. Minimaul

    Minimaul Site owner Staff Member

    Hey,

    I'm aware of some materials brokenness with CustomizationItemClone at the moment. The extra validity checks in the newer versions (which cause a lot of items to fail to clone) are a result of this.

    I've been trying to find some time to fix it properly, but it's tricky stuff to work with.

    Yep. This isn't implemented yet.
     
  4. smashbro596

    smashbro596 Modding patch tester

    whenever i try to use the stream to build asm files it opens with a blank screen then closes
    and any time i run the updater i get this error
    Unhandled Exception: Newtonsoft.Json.JsonReaderException: Unexpected character encountered while parsing value: C. Path 'paths.sriv', line 5, position 12.
    at Newtonsoft.Json.JsonTextReader.ParseValue()
    at Newtonsoft.Json.Linq.JContainer.ReadContentFrom(JsonReader r, JsonLoadSettings settings)
    at Newtonsoft.Json.Linq.JContainer.ReadTokenFrom(JsonReader reader, JsonLoadSettings options)
    at Newtonsoft.Json.Linq.JObject.Load(JsonReader reader, JsonLoadSettings settings)
    at Newtonsoft.Json.Linq.JToken.ReadFrom(JsonReader reader, JsonLoadSettings settings)
    at ThomasJepp.SaintsRow.Settings..ctor()
    at ThomasJepp.SaintsRow.Utility.GetGamePath(GameSteamID gameId)
    at ThomasJepp.SaintsRow.Stream2Update.Program.Main(String[] args)
     
  5. Minimaul

    Minimaul Site owner Staff Member

    If I had to guess, you've messed up your settings.json.

    If you attach the file to this thread, I'll take a look.
     
  6. smashbro596

    smashbro596 Modding patch tester

    here ya go mini
     

    Attached Files:

  7. Minimaul

    Minimaul Site owner Staff Member

    Yep, you missed off the quotes around the path - what you put in is not valid JSON.

    Here's a corrected version.

    Code (Text):

    {
      "paths": {
        "sr2": null,
        "srtt": null,
        "sriv": "C:\\Program Files (x86)\\Steam\\steamapps\\common\\Saints Row IV",
        "srgooh": "C:\\Program Files (x86)\\Steam\\steamapps\\common\\Saints Row Gat out of Hell"
      }
    }
     
     
  8. Having another issue with the cloning tool that I don't remember encountering before. Tried v120 and 121. Whenever I try to clone Fumigator 3000 I get this error:

    C:\Users\Gruff\Desktop\ThomasJepp.SaintsRow-rev121>ThomasJepp.SaintsRow.Customiza
    tionItemClone "cm_gasmask" "gruff_facewear_gas_mask"
    Mapping mesh cm_mask_gasmask.cmeshx -> cm_gruff_facewear_gas_mask.cmeshx
    Mapping mesh cf_mask_gasmask.cmeshx -> cf_gruff_facewear_gas_mask.cmeshx
    Mapping cloth sim cm_mask_gasmask.simx -> cm_gruff_facewear_gas_mask.simx

    Unhandled Exception: System.IO.IOException: An attempt was made to move the posi
    tion before the beginning of the stream.
    at System.IO.MemoryStream.Seek(Int64 offset, SeekOrigin loc)
    at ThomasJepp.SaintsRow.Meshes.StaticMesh.StaticMesh..ctor(Stream s)
    at ThomasJepp.SaintsRow.CustomizationItemClone.Program.ProcessCCMesh(IPackfil
    eEntry oldFile, String oldName, String newName)
    at ThomasJepp.SaintsRow.CustomizationItemClone.Program.ClonePackfile(IGameIns
    tance sriv, String packfileName, String clothSimFilename, String outputFolder, I
    AssetAssemblerFile newAsm, String oldName, String newName, String newStr2Filenam
    e)
    at ThomasJepp.SaintsRow.CustomizationItemClone.Program.Main(String[] args)


     
  9. smashbro596

    smashbro596 Modding patch tester

    ok that fixed one issue
    but whenever i open stream it still only shows a black box for like a second then closes.

    im trying to make an asm file. 3 actually.
     
  10. Minimaul

    Minimaul Site owner Staff Member

    If you're using ThomasJepp.SaintsRow.Stream2, it's a commandline tool - you need to use it from cmd.exe or write a batch file.

    I can see a few possibilities for that one. I'll have to try cloning that specific file.
     
    Last edited: Apr 22, 2017