1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Gentlemen of the Row (Gibbed.SaintsRow2.BuildPackage has stopped working)

Discussion in 'Get Help/Troubleshooting' started by bigboiben, Jul 27, 2018.

  1. Hi, I'm Trying to create a custom patch for GotR and I'm running into a issue where the .Bat file creates a 0 byte patch.vpp file accompanied by the error Gibbed.SaintsRow2.BuildPackage.exe has stopped working.
    If I close Gibbed.SaintsRow2.BuildPackage.exe the .bat file says my build is complete despite it creating a blank patch file.
    The vanilla build also does not build correctly either. Returning the same error.
    .I have completely disabled and exited my AV
    .Re-extracted the GotR Archive (.rar) with winrar.

    I am using windows 7 64bit and have successfully built a custom patch in the past.
    Attached is a Screenshot of the Issue.
    Any help would be appreciated as playing SR2 is needed in life! LOL
     

    Attached Files:

  2. If I recall correctly, I had the same error back when I used to have Windows 7 installed. Using Windows 7 requires you to run the .bat file as Administrator or you'll run into the same issue.
     
  3. Thanks for the reply.
    No luck. Running the .bat file as Admin returns the error. Warning - Optional Mods folder doesn't exist. Did you forget to extract the whole archive?
    The Archive is extracted and the .bat file is ran from the folder.
     
  4. [V] IdolNinja

    [V] IdolNinja Volition Staff

    The archive is not extracted correctly and missing files. Make sure you are using either the latest 7zip or winrar, and not winzip.
     
  5. Archive is extracted with latest winrar and is not missing any files and is the correct size after extraction. The Optional Mod does not exist only occurs when running as Admin. The folder is present and running the .bat file normally takes you into the custom installer but then fails with the error mentioned previous after entering P.
     
    Last edited: Jul 27, 2018
  6. Where did you even extract the GoTR files? Mine are extracted to "C:\Program Files\Steam\SteamApps\common\Saints Row 2" . Steam version. and I also have a Gog version and GoTR is extracted to "E:\Program Files\GOG Galaxy\Games\Saints Row 2" , which is on a secondary HDD.

    My GoTR setup looks like this on Steam version:
    Screenshot_1.png

    My GoTR setup looks like this on GOG version:
    Screenshot_2.png

    Also, make up your mind, earlier you said the "Optional Mods folder doesn't exist. Did you forget to extract the whole archive?" , well, look at both of my setups, do you see a "optional_mod_stuff" in the screenshots? Mine is there cause I extracted the whole complete Gentlemen_of_the_Row_Saints_Row_2_Super_Mod_v1.9.2.rar files into both of my game install folders.
     
  7. Thanks for the Reply
    As stated previously the "optional mods does not exist" only occurs when running the .bat file as administrator. When running normally without selecting run as administrator the "optional mods does not exist does not appear and the custom installer runs fine until you enter p to build. The optional mods folder is 100% there I can assure you. I would not post a thread for such a simple oversight.
    I'm not with my PC at the moment. But when I am I can compare my folder to yours. From memory they look the same. I have extracted GotR to both the game directory N:/steamlibrary/steamapps/common/saints row 2 and to the desktop. Both result in "gibbed......build.exe has crashed. Worth trying a different version of gibbed tools maybe?
     
  8. [V] IdolNinja

    [V] IdolNinja Volition Staff

    The optional mods folder can exsit, yet still be empty and cause that error. Screenshot the contents of that folder.
     
    FusionH2o likes this.
  9. Mine looks like this:

    Optional mod stuff:
    Screenshot_3.png

    What it looks like in the optional_mods folder:
    Screenshot_4.png

    I know my files extracted well.
     
  10. I'm away at the moment so can not screenshot but the optional_mod_stuff folder is not blank and appears identical to Fusion's. This issue is leaving me scratching my head as all known and previously stated fix's are not working. When I'm back at home I will further investigate and provide more screenshots. Thanks.
    If you guys could think of some troubleshooting ideas as well it would be very helpful as I could have missed something that I could try.