1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SR FBX converter problem with axis

Discussion in 'Get Help/Troubleshooting' started by Henry08, Apr 21, 2017 at 10:45 AM.

Tags:
  1. I'm using Maya with Up axis Z and centimeters as unit and after converting my weapon I got problem
    Force 3dmax Up In
    [​IMG] [​IMG] [​IMG]
    All Ok except the size
    Force Maya Up Z cm
    [​IMG] [​IMG]
    size is normal but preview is not so good
    Maya with Y-up centimeters
    [​IMG]
     
  2. flow754

    flow754 Modding patch tester

    Hmm, I'd go with the Y-up, centimeter version, but make some changes in maya. First unbind your mesh from your rig then rotate "bone_root" 90 degrees on the x axis in maya, then remove all history and bind your model to the skeleton again.
     
  3. I tried few times to rotate an freeze transform after, result is strange, model looks ok on the preview but in game like in the last shot. Or do you propose to rotate only bones?
     
    Last edited: Apr 21, 2017 at 12:29 PM
  4. flow754

    flow754 Modding patch tester

    Yes only the bones.
     
  5. Sadly but I could not get the result I needed :( What your recomendation about Maya axis, FBX export settings? I always used Zup in maya and Y convertion in the exporter with "Force 3dmax Up In" in SDK for clothes and everything worked Ok