Game crash on load and new game... PLEASE HELP!

Discussion in 'Get Help/Troubleshooting' started by greatknight22, Feb 11, 2017.

  1. i didn't have problems with this until i download the new Gentlemen of the Row, but even removing patches and using vanilla patches, hell, even after deleting my save data, nothing changes.


    Processor
    AMD FX(tm)-8350 Eight-Core Processor

    Video Card
    AMD Radeon R9 200 Series

    RAM
    16 GB

    Operating System
    Microsoft Windows 10 (build 14393), 64-bit
     
  2. I have Windows 10 and Windows 7 dual boot. I always have to right click (Run As Administrator) in Windows 10 but not in Windows 7.
     
  3. i'm having this issue aswell. Did you ever fixed it??
     
  4. You may be missing DirectX 9.0c on your computer.
    1. Download DirectX 9.0c redistributable from June 2010 from Microsoft’s official website.
    2. Run directx_Jun2010_redist.exe.
    3. Follow the instructions on the screen. This setup will extract the necessary files to the folder of your choosing.
    4. Once the setup closes, open the folder to which you extracted the files.
    5. Run DXSETUP.exe as administrator and follow the instructions on the screen.
    6. Restart your computer.
    7. (Optional) Remove the folder with the extracted installation files if you wish to conserve space. This is perfectly harmless, as the files have been installed in the proper system folders.
     
  5. Thank you for the response, but i tried it and i still having the "Sr2_pc.exe has stopped working"... thing.
     
  6. Read the file titled "Saints Row 2 PC FAQ.txt" in the directory you extracted GotR to.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice