1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

ExtractPackfileGUI Virus/Malware ????

Discussion in 'Get Help/Troubleshooting' started by Soulbringer, Jul 4, 2017.

Tags:
  1. Avast Insists that The file is Malware. I flagged it as a False Positive. They still insist it is Malware.

    What up with that???
     
  2. flow754

    flow754 Modding patch tester

    None of Minimaul's tools are malicious. In fact you can check their source code and compile them yourself if you still have doubts. However, if you downloaded the tools from this site, there's nothing to worry about.
     
    JigglyGruff likes this.
  3. Avast is stupid. LOL. it was a bad download. I found the right one, Just had not had the time to reply on here. Thanks for the Reply. :)
     
  4. I think there is something that is decaying the program, cause after using it a few times it stops working.
    1. So I just Google what I mentioned about Programs not working after a while
    2. Jamieh2k7's last answer [Click here for Link] and said he saw errors in the Event Viewer
    3. I looked in my Event Viewer and this is what I saw

    - Under Windows Logs > Applications > MiddlePanel
    = A .NET Runtime Error before an Application Error of ThomasJepp.SaintsRow.CustomizationItemClone.exe
    app.png Image of Application & Security Logs & Detail
    Code (Text):
    Application: ThomasJepp.SaintsRow.CustomizationItemClone.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.OutOfMemoryException
       at System.Text.StringBuilder.ExpandByABlock(Int32)
       at System.Text.StringBuilder.Append(Char, Int32)
       at System.Text.StringBuilder.Append(Char)
       at ThomasJepp.SaintsRow.StreamHelpers.ReadAsciiNullTerminatedString(System.IO.Stream)
       at ThomasJepp.SaintsRow.Meshes.StaticMesh.StaticMesh..ctor(System.IO.Stream)
       at ThomasJepp.SaintsRow.CustomizationItemClone.Program.ProcessCCMesh(ThomasJepp.SaintsRow.Packfiles.IPackfileEntry, System.String, System.String)
       at ThomasJepp.SaintsRow.CustomizationItemClone.Program.ClonePackfile(ThomasJepp.SaintsRow.GameInstances.IGameInstance, System.String, System.String, System.String, ThomasJepp.SaintsRow.AssetAssembler.IAssetAssemblerFile, System.String, System.String, System.String)
       at ThomasJepp.SaintsRow.CustomizationItemClone.Program.Main(System.String[])
    Code (Text):
    Special privileges assigned to new logon.

    Subject:
        Security ID:        SYSTEM
        Account Name:        SYSTEM
        Account Domain:        NT AUTHORITY
        Logon ID:        0x3e7

    Privileges:        SeAssignPrimaryTokenPrivilege
                SeTcbPrivilege
                SeSecurityPrivilege
                SeTakeOwnershipPrivilege
                SeLoadDriverPrivilege
                SeBackupPrivilege
                SeRestorePrivilege
                SeDebugPrivilege
                SeAuditPrivilege
                SeSystemEnvironmentPrivilege
                SeImpersonatePrivilege

    4. So I test tried using the Run as Administrator from CloneTool's Properties = Run the .BAT and it still filled up my RAM & CPU bank

    = All Other Events under Security Logs are via Right-Click > Event Properties
    - Anonymous Logons (Connection Related not Hackers), LOCAL SERVICE and SYSTEM, etc
    5. Tried Run as Administrator from CloneTool's Properties & Compatibility Mode for Windows
    FAILED1 = Unhandled Exception: System.AccessViolation: Attempted to read or write protected memory. This is often an indication that other memory is corrupt
    = 95, 98/ME
    FAILED2 = Closed it before it used up to 3.5GB and gave a "Out of Memory", notice it jumps from 10-15K to 60-90K to 200K per jump
    = NT4.0, 2000, XPsp2, XPsp3, Server2003, Server2008, Vista, Vista2sp, Vista3sp & 7
    NOTICED ABOUT FAILED 2 = The jump in RAM use starts after the files appear
    Mapping mesh cm_lp35h_suit_f_fbot.cmeshx -> cm_lukong1515_outfit_femjet.cmeshx
    Mapping mesh cf_lp35h_suit_f_fbot.cmeshx -> cf_lukong1515_outfit_femjet.cmeshx
    ALSO
    When other files succeed its cmeshx > cmeshx > simx, but when they fail either by Out of Memory or Material! problem its when it gets to simx

    PROBABILITY = PROBLEM FINDING FILES SR4 DIRECTORY
    ALTERNATIVE CONCLUSIONS
    = Your Tools were compromised by a Banned Member who is a Hacker and has used your file to hack all of us...and The Princess is in the Next Castle
    = Flow's Tool & Minimaul's Tools are Conflicting = why Flow's Instruction are to not put these tools in the same folder...maybe their is something Flow's Tool causes your tool to stop working like you've changed something another tool is looking for (AND I HAVE THEM IN SEPARATE FOLDERS)
    6. Tried copying the Framework Version to download the right Framework...4...it said I already have it

    7. All Failures Produce Empty Folders

    = rev131 = materialsize != material.Datasize -256! = 328 (This didn't use up RAM)
    = rev130 = materialsize != material.Datasize -256! = 328 (This didn't use up RAM, tested last)
    = rev128 = materialsize != material.Datasize -256! = 328 (This didn't use up RAM, This isn't the rev128 from Minimaul's Thread, but this is from Minimaul's Releases Link not the Forum Page also tested this after rev121)
    = rev121 = File progress wasn't shown & ran up memory
    = rev120 = File progress wasn't shown & ran up memory
    = rev110 = File progress wasn't shown & ran up memory
    = Anything older doesn't work instantly...
    8. Conclusion an Update is needed (Clone Tool might be causing all the Problems cause it came after rev108), but I've noticed after 20 or so .BAT Runs it stops working maybe the Tool as it Clones adds a New Spot for the Item and cause its not used the Limited amount of Slots run out
    9. ANSWER = FOR CUSTOMIZATION ITEMS, CERTAIN NAMES DON'T WORK...YOU'LL HAVE TO FIND ALTERNATIVE NAMES/ITEMS OR SKIP
    REV121 Test
    - Bad using rev121: Bahamut Suit, cm_lp35h_suit_f_fbot (Femme Bot), spider earrings

    - Good using rev121: cm_suit_normaltestsuit & cm_hat_elephant_mask

    Why did I tested those Clothing Items:
    - Bad = must have underspaces and certain ones don't work
    - Good = All had underspaces, it didn't matter how far down the list it was and what type of clothing it was (suit)

    REV131 Test (Every other as well)
    - ALL FAILED with rev131, with BAD's of rev121 they actually didn't end instantly
     
    Last edited: Jul 23, 2017 at 11:18 AM