1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XBox 360 Controller doesn't work

Discussion in 'Patch Suggestions and Bug Reports' started by Quantum, Jun 8, 2017.

  1. Quantum

    Quantum Modding patch tester

    I haven't played SR4 in a while, and I noticed with the latest patches my XBox 360 controller doesn't work when the game starts. It used to always work fine. The XBox 360 controller always works fine with all my other games, and it works fine in Steam Big Picture mode.

    I am able to make it work if I unplug the controller from the USB port and plug it back in while the game is running, but even this doesn't always work the first time, and this is very inconvenient. The keyboard always works.

    I tried running SR3 and SRGOOH, and they have no problems at all. They always recognize the controller, just like my other games. Only SR4 has problems.

    I have removed all mods.
    I have verified the integrity on Steam.
    I rebooted to make sure all other programs were not running.

    My system is running Windows 8.1 (64 bit).
    My game Build ID is 1598311.

    Could it have something to do with the Steam Controller support that was added?

    If there's anything I can do to help diagnose this issue, let me know. Someone posted a similar issue on the Steam forum in December. That's right around the time when Steam controller support was added.


    UPDATE:
    Apparently it's something Steam broke in a recent update, according to this topic on the Steam forum. It is related to the Steam controller support, which apparently SR4 uses but the other games don't. It looks like they broke it around June 2 and it's still not working.
     
    Last edited: Jun 8, 2017
  2. Quantum

    Quantum Modding patch tester

    FYI: Steam's latest update tonight seems to have fixed it. My controller now works when the game starts.