1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Powertools slowdown

Discussion in 'Get Help/Troubleshooting' started by camranbant, Jan 2, 2018.

  1. With powertools installed and the percentage value set to anything under 1, the game runs ridiculously slow, even the THQ/volition splashscreens run too slowly. If I set the value to 1.0 then the game runs too quickly, just like it would without powertools.

    With the fps unlocked the game runs closer to the speed it should, but will speed up and slow down depending on what's on screen. I'm using the Steam version, windows 10 and GOTR 1.8, any ideas how to fix this?
  2. How do I fix this? I've tried the auto version of powertools and that sets the gamespeed too slow. Powertools can't keep the gamespeed consistent when I set it manually. With v sync on and off, frame limiter on and off. Why?
  3. Powertools isn't made to run on Windows 10. Windows 10 doesn't have the speedbug. Powertools is made for the Windows 7 speedbug.
  4. It does, but my mistake, I forgot about the useplatformclock fix for win 10. Game runs full speed but now my fps has dropped to 25-40, I was getting a fairly stable 80fps maxed out before.

  5. Can you try to restore your system to a date before the FPS drop started? Also, it might help if you defrag your system, which was a problem on my end.
  6. I turned useplatformclock off and I'm back to 60-80fps, with the speedup bug. Is there no fix for win 10 that doesn't involve killing your framerate?
  7. Inconsistent game speed might be worsened or, combined with Powertools, caused by dynamic lighting. It won't fix the speedup bug itself but try lowering the setting to see if it makes the game run a bit smoother, to rule it out as a cause at least.
  8. with useplatformclock true the framerate was still unplayable.

    with useplatform clock off + powertools the game runs really slowly no matter what my graphics options are; even the intro videos run really slowly
  9. Ok, good to hear it wasn't because of dynamic lighting, at least. I have that issue on my current pc and there's no fix for it.

    Just to make sure - you've been trying to manually find the correct percentage for Powertools by using the stopwatch test, right?
  10. i haven't even got that far yet, if i set it to anything under 1 it runs a lot slower than it should do. At 0.99 it happens, at 0.999 it rounds up to 1 and runs as it would w/out powertools