Mission_start function not working.

Discussion in 'Rejected bugs' started by Erza Scarlet, Mar 29, 2015.

  1. Erza Scarlet

    Erza Scarlet Modding patch tester

    In Saints Row IV I am currently trying to use the Mission_start("mission name", true) function to load a mission but unfortunately it isn't working, but I have found that it works perfectly in Gat out of Hell.

    In the attached sr3_city.lua you can see that i'm trying to use R + Right arrow key to initiate the mission.


    When i started working on this I planned on creating a whole new section in the hub which would allow users to select from a list of missions and replay them, which would be reintroducing the mission replay feature from SR2.
     

    Attached Files:

    Last edited: Mar 29, 2015
  2. [V] Knobby

    [V] Knobby Volition Staff

    The mission is locked. Call mission_unlock("m00") first.
     
  3. Erza Scarlet

    Erza Scarlet Modding patch tester

    Thanks, it works now. Before I tried will all the other missions but none of them worked and I also asked Minimaul and he said it was an issue where sometimes it would work and sometimes it wouldn't so that's why I made this post. Thanks for your help.
     
    [V] Knobby likes this.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice