1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Missing interiors (weapon limit?)

Discussion in 'Modding Patch Beta' started by Fan of Saints, Mar 1, 2018.

  1. Fan of Saints

    Fan of Saints Modding patch tester

    I launched Saints Row IV after a few months of break to check new Workshop items. Everything worked as usual... Until I attempted to enter a store. Door didn't open after pressing the action button. Then I tried to go through the wall using Loa dust from vendor menu and there was nothing inside, I got stuck in mid-air. Game froze on black screen when I tried to go back to the main menu.

    I tried again and again, it happened every time. I removed old format mods and even verified the cache, nothing. I removed some random Workshop mods and interiors started working again. I messed around a little and found out it's related to weapon mods in particular. Interiors loaded properly after deleting few old weapon mods, which worked perfectly yet when I played Saints Row IV last year.

    The question is, what's the actual cause? How many weapon entries is it possible to add in the new modding format before it all collapses? There must be a limit somewhere, I never had such issue before. I'm currently subscribed to 98 Workshop mods, I'll try to count weapon ones later.
  2. flow754

    flow754 Modding patch tester

    Huh, that's weird. Seems worth investigating, but there doesn't necessarily have to be a limitation - maybe any single one of your 98 mods was faulty and caused those bugs. It's also possible that two or more of your mods are conflicting, so it might be a hard one to debug :/