1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

How to Setup an CVTF for a Variant Vehicle for a Mod ?

Discussion in 'Modding Patch Beta' started by SaturnSaint, Feb 25, 2017.

  1. SaturnSaint

    SaturnSaint Modding patch tester

    i really like to edit an Car Variant in SRIV but i dont know how i need setup the CVTF at all
    Could someone Pls Help me ?


    well i tried my self to edit an Batch file adding vehicle_table_cruncher from Zynak Cache of Wonders
    adding the vpkg_wd file from Zynak Cache of Wonders and etc..... but it didnt worked

    my Files is look like this , these files were from Idolninjas Tools sorry but i tried to setup for SRIV

    my_variant_files
    Code (Text):
    car_4dr_police02_0
    car_4dr_police02_1
    car_4dr_police02_2
    car_4dr_police02_3
    NEW_MODDED_FILES
    original_asm
    tables
    1_crunch.bat
    2_package.bat
    3_asm_combine.bat
    4_move_and clean up.bat
    car_4dr_police02.cvtf_pc
    vehicle_table_cruncher.exe
    vpkg_wd.exe
     
  2. SaturnSaint

    SaturnSaint Modding patch tester

    here are all my files to check out what is the Problem

    Can someone Pls Help me
     

    Attached Files:

  3. [V] IdolNinja

    [V] IdolNinja Volition Staff

    We're going to need more info. What exactly didn't work? Did the files not crunch/get created? Did it crunch but the output files crash the game? Is the game okay but doesn't show your changes? Did the crunch tool set your cat on fire and now you're too sad to play?
     
  4. SaturnSaint

    SaturnSaint Modding patch tester

    i am sorry to being a long off time busy

    1. the cvtfs files are successfuly crunched but it cant package files with 2_package.bat and vpkg_wd idk why but it saying something that the vpkg_wd cant find the steam_api my opinion this is the problem ( i cannot open or package vpkg_wd.exe) can you or someone figure out how can i open or package the vpkg_wd.

    vpkg_wd is from zynack cache of wonders downloaded
    my plan is to get back Unmarked Peacmaker from SRTT to SRIV

    thank you for reply
     
    Last edited: Nov 3, 2017
  5. Miku Hatsune

    Miku Hatsune Modding patch tester

    It's been a long time for me it feels like.
    vpkg_wd.exe is looking for the steam_api.dll found in the root where you can find SRIV's EXE. I've moved the tools on my end to that directory, but it's still having issues.
    vpkg_wd.exe on my end fails to find access point of procedure SteamUGC in vpkg_wd.exe.

    I've tried any and all other methods of packing a vehicle, but the output is filled with issues after packing. I've tried suggestions from Knobby and have tried a bunch of things my own, but literally nothing works. I'd be very happy if Knobby himself could just try to crunch and pack a vehicle and update the ASM with the exact tools that we've been provided. At this point that would be much much more efficient. If it doesn't work he has something nice to troubleshoot, and if it does work, he can tell us the steps he has taken.
     
    Last edited: Feb 8, 2018