1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

HELP! Saints Row 2 Not Launching (Windows 10)

Discussion in 'Get Help/Troubleshooting' started by greasyguavas420, Aug 30, 2017.

  1. First of all, my specs:

    CPU: Intel Core i7-6700K@4.2GHz
    Motherboard: Gigabyte Z170-HDP3-CF
    RAM: CORSAIR Vengeance LPX 32GB (4 x 8GB) DDR4-2400
    Storage: SanDisk x400 512GB SSD (My OS and Saints Row 2 are installed on this drive) / Toshiba 3TB Internal SATA Hard Drive (I have tried installing it on this one too, still doesn't work.)
    GPU: Zotac NVIDIA GTX 1080 8GB GPU
    OS: Windows 10 Home x64

    Now, the issue:

    Saints Row 2, when launched from either Steam, a desktop shortcut, or the executable itself, fails to open a window at all. No error message, no crash message, no black screen, just, nothing. I get a loading wheel on my mouse for a fraction of a second, and then, nothing. Steam briefly says I have the game open, and then immediately reverts back to just "Online" status.

    Here's everything I have tried to mend the issue (And yes, I have tried combining all of these fixes in every way possible. Still nothing.):

    Running as an Administrator.
    Running in Windows XP (Service Pack 3), Windows 7, and Windows 8 Compatibility Mode.
    Running in Reduced Color Mode (8-bit, 256 colors).
    Running in forced 640x480 resolution.
    Overriding high DPI scaling behavior to Application, System, and System (Enhanced) modes.
    Disabling fullscreen optimizations.
    Installing DirectX 9 manually.
    Installing DirectX via the installer in the game directory.
    Reinstalling the game.
    Installing the "Gentlemen of the Row" mod, with various combinations.
    Reverting back to Vanilla from a GotR installation.
    Deleting all save files.
    Manually creating a settings.dat file in AppData\Local\THQ\Saints Row 2.
    Installing the game on different drives. (C: (my SSD) and D: (my HDD))

    Conclusion:

    I have tried everything the internet has told me to try in order to fix this, and gotten no results. I've never had to create a forum post for an issue I've had ever before, so I hope I did this right. Any help is appreciated. I'd love to be able to play this game again. Thanks in advance.