1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Game freezing in "Escape Mission"

Discussion in 'Patch Suggestions and Bug Reports' started by ReddPyramid, Apr 2, 2016.

  1. There is no entry in Event Viewer. About 48 entries for Saints Row 2, because of course there is [big thanks to IdolNinja's Gentleman of the Row mod, without it that game would have been utterly unplayable]. But now I have this stupid crap. I upgraded to Windows 10 because whatever my personal vendetta against the direction Windows is taking, having to upgrade is inevitable.

    Problem: Game freezes in mission "Escape" singleplayer campaign.

    Not always in the same place either. This last time it froze after the cutscene with Kinzie and 'Boss' in the ship, 'Boss' asking to fly. The pixel effect that is the transition between that cutscene and the next playable sequence froze up, with no sound. I had to alt tab, CTRL ALT ESC, Task manager, select the program with arrow keys and ALT E to end it, because when it does this, my mouse takes an effing vacation until I kill the offending process, SRIV.

    Steps I personally took to attempt resolution:

    -Verified Game Cache in Steam. Twice.
    -Deleted entire game directory and completely reinstalled.
    -No mods. Perfectly vanilla install.

    The game is also installed on the C: drive because I'm one of those 'lucky' people whose machine flips monkey shite if the game is installed anywhere else.

    System Specs:
    OS: Windows 10
    CPU: 2x Intel Xeon E5472 [Quad Core Workstation processors]
    RAM: 32 GB ECC DDR2
    MoBo: Dell Inc. 0RW199 [Dell Precision T-7400 Stock]
    Graphics: AMD Radeon R-9 270
    The computer itself is a modified Dell Precision T-7400 workstation, and handles most things like a champ. Previous to the 'upgrade' to Windows 10, it handled this game like a champ too.

    Prior to the upgrade to Windows 10, I clocked in over 50 hours on this game with zero issues. So I know my computer can run it, and run it well. This problem is driving me up a wall, and any help would be appreciated. I looked into the threads for my problem and have searched Google to no avail. If a fresh reinstall didn't fix it, if verifying the cache didn't fix it, if doing all of the above and starting a new character didn't fix it, I am out of options. Attached you will find the MSInfo32 file as per the form request.

    I vaguely recall having to do something with my multiple core processors with either this game or Saints Row The Third, and if that is what the problem is, please remind me how/what I have to do, because I can't remember how I did it before, only that it was in Task Manager... and Task Manager has changed in Win10.

    This is my first post so forgive me if I have left out any information you might need, but as stated above, there is no Event Viewer Report for SRIV, and I'm thinking this is because it doesn't 'crash', it hangs/freezes, and therefore was User-terminated.

    Edit: Spelling. Angry at the keyboard whoops.

    Edit 2: Got the game to work, now, by doing what I don't know. I set the game to only use two cores, and reinstalled DirectX. But now I have a new problem, because of course I do. The tutorial for the stomp power is broken. I am told to stomp and kill enemies, and they just flail and fall, taking no damage in the tutorial. So I can't move on with the game. So that's fantastic. Don't get me wrong, I play Fallout, so bugs, I am no stranger to, but this is getting ridiculous. Jumping through all sorts of idiotic hoops to get a game to work is just unreasonable. I've quit out of the game, and will try again, but I am not looking forward to fighting that tedious warden again. Tedious. Now that's a word. Games are by nature supposed to be fun. Not tedious slogs.

    Edit 3: The mission didn't come up when I tried to load the game again. No Warden appeared upon re-entry into the simulation after rescuing Matt, and the game is still doing the stupid freezing thing. It did it just now for no apparent reason and I had to go through the task manager song and dance yet again to get my freaking mouse back. Seriously, someone please help me out here. I want to play the game I paid money for.
     

    Attached Files:

    Last edited: Apr 2, 2016
  2. [V] Knobby

    [V] Knobby Volition Staff

    Completely grasping at straws here, but did you try compatibility mode? WIthout crash dumps or something I don't know what I can do to help here. The problems you're describing sound like a mod gone wrong or just broken data, but you say no mods and verified data. Maybe a memory issue? Seems odd to correspond with Win10 though.
     
  3. I have no idea what the problem could be. I did eventually get through the game, but I didn't enjoy it nearly as much as I would have if I didn't constantly have to wonder 'will it or won't it crash'. Rebooting the computer didn't help, reinstalling the game several times didn't help, but compatibility mode isn't something I tried. I also know some people say 'try it in windowed mode!', but call me a snob if you like, but I didn't put this computer together the way it is for me to play games in windowed mode. I love these games so, so much. I never was a fan of GTA or anything like it until someone got me to try Saints Row The Third, and I even went back and patiently worked through the crashes in SR2 to play that game on my pc as well. I plan to get a copy of the first game as soon as I can.

    Thanks for getting back to me, I'll try compatibility mode.

    Edit: With 32 gigabytes of RAM and only 4 GB of that ever being used by the system, I don't think it could possibly be a memory issues. Volition isn't IMVU, your games are pretty stellarly designed as far as resource management goes. IMVU can eat up all of my excessive ram because it's poorly written, but i don't see your games doing that [unless it's the awful SR2 pc port, but we won't talk about that xD]