FPS locked at 5 ?!

Just what the title says.....
I didn't have this issue before but recently fps dropped drastically to only 5 fps and locked I don't really know why, therefore, it's so unplayable at this point, and what's even more frustrating that I tried all the famous and possible solutions out there ( for Nvidia users like me ofc )

1-low latency at ultra
2-frame rate at 120
3-VS at fast
4-Ran as administrator
5-Ran compatibly for windows 8

I basically did everything to make sure that I won't waste anyone's time making this thread cause for some reasons people keep saying those methods mentioned above fixed their game. Question is why my game isn't responsive to those methods ? Besides, what is wrong I'm doing here ?
I really couldn't take any in-game screens cause like I said, it's really unplayable.

SRTTR 2022-12-08 21-37-52-44.jpg

Update:
Removing workshop stuff from Saints Row IV solved the problem. I don't even know what is the connection here but after the removal I now have full FPS and I'm actually able to play it again.
 
Last edited:
Top