EGS 7th patch introduced micro-stutter and a 67fps lock. Has anyone managed to fix either of these?

So a while back, when the latest patch for the Remaster was deployed via EGS, I noticed it had introduced a horrific level of microstutter to the Remaster, as well as a full 50-70% FPS tank, each time I crossed district zones. I also read several posts and reports (DSOGaming website, for example,) from people who were now experiencing a 67fps lock, (although I personally wasn't dealing with that problem.)

I put my ticket into Koch support, via their website, but all of the suggestions they've come up with have been for out of date Windows 10/Nvidia driver builds, for the wrong game, (lol o_0) or generally useless.

I run a pretty modest rig, but had zero issues with the original EGS release, and everyone I know who has these issues now had a similarly smooth experience at launch.

My PC: 3570k @ 4.0 gig, 24gb ram, GTX 1080 8Gb, Samsung SSD, 144Hz gsync ROQ monitor.

I'm now seeing a bunch more reports from new players who've picked the game up, and they're also experiencing the same issues.

Has anyone who has had these problems, managed to fix them? Be it via hardware/software tweaks, or through modding? I'd love to hear from anyone who could help, since Sperasoft are dragging their knuckles with both a fix, and with communication.
 
It’s not patch 7 that introduced it, it was the latest Windows update.
Same behaviours occur on 1909 Windows 10 builds. It wasn't the 2004 build.

To fix, enable Fast Sync in NVC
Doesn't help.

Also, Fast Sync only activates when a game's framerate is higher than the monitor's refresh rate. Since Third Remastered is hardlocked to 120fps, which is lower than my native refresh, I wouldn't have expected it to, either.

Thank you, tho. I'm going to try yesterday's nvidia drivers, and will report back.
 
Same behaviours occur on 1909 Windows 10 builds. It wasn't the 2004 build.


Doesn't help.

Also, Fast Sync only activates when a game's framerate is higher than the monitor's refresh rate. Since Third Remastered is hardlocked to 120fps, which is lower than my native refresh, I wouldn't have expected it to, either.

Thank you, tho. I'm going to try yesterday's nvidia drivers, and will report back.

I've had the version that comes before 1909 (don't remember the number), the framerate was fully unlocked. Once I've updated to 2004, received a hard lock at 67fps. So I guess problem occurs from 1909 and onward.

As for conditions at which fast sync works and the FPS cap of the game don't really matter here as enabling fast sync is what fixed the problem for me.

I'm on 446.14 drivers, in-game V-sync is off, NCP fast sync + G-sync. Hopefully you can solve the problem
 
It's 1440p 144Hz
Thanks. I'm trying to replicate your environment, but not getting positive results so far. If you've got a mo and could indulge me a little:

Low Latency Mode set to Ultra? Do you disable fullscreen optimizations for the executable? gsync for fullscreen, or fullscreen & windowed?

Edit: also - no change with yesterday's 451.67 driver set.
 
Thanks. I'm trying to replicate your environment, but not getting positive results so far. If you've got a mo and could indulge me a little:

Low Latency Mode set to Ultra? Do you disable fullscreen optimizations for the executable? gsync for fullscreen, or fullscreen & windowed?

Edit: also - no change with yesterday's 451.67 driver set.

Sure, Low Latancy set to ultra (global). Did not touch any setting on the executable, so default. Gsync - Fullscreen and Windowed.

Also, NCP global settings - V-sync on. In Program Settings only for the game - fast sync on. Also just for the game, I've set Maximum Performance in Power Management mode, probably doesn't make any difference and I guess I've set it like this just because was trying to figure out a solution for the problem.
 
No change with the July 2004 Cumulative Update. Nothing from Sperasoft. I'd refund the game, if that were a thing, but it isn't.

Last Saints product I buy from anyone but Volition.
 
Looking online, this is the recommended settings:
> Exe: full-screen effects disabled
> Nvidia CP: V-sync fast
> In-game: V-sync on

But still there is stutter. High speed, turning corners and crashing exacerbates it I think. Most of the time 60fps, but random dips into as little as 27fps on a GTX 2060.
Whats more, the stutter is identical to that in SR2 eleven years and umpteen PC upgrades ago. Tut tut.

Booting up GTA5 or Burnout PR and the difference in smoothness is alarming.
 
Last edited:
Top