1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Can't enter courthouse in Appointed Defender

Discussion in 'Get Help/Troubleshooting' started by theg721, Apr 7, 2018.

  1. Hi,

    I'm trying to play SR2 on the Xbox 360 but am stuck on the second mission. I can't enter the courthouse because the doors won't open. The hand icon appears, and the door opening animation plays but the door remains closed.

    I was playing from the disc but have also tried installing it to the hard drive and buying a digital copy. I've also tried creating a new profile on the Xbox, using a different storage device, going to the courthouse before the mission, etc. Pretty much anything I could think of. I've already looked around online and tried everything I found (which wasn't very much) but with no success. I'm not really sure what else to try and would appreciate any ideas!
     
  2. This never happened to me before on the Xbox 360 or PC, so I don't know.
     
  3. you honestly might have a corrupted copy. this happened to me in tony hawks american wasteland, i got stuck in the level transition and the next level never loaded.