1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

An help with modding Sr3

Discussion in 'Get Help/Troubleshooting' started by TheToxicAlien95, Aug 13, 2017.

  1. Hi everyone i am new here, i like these games and this community, so i have joined to learn something with modding.
    So, i have got problems with modding saints row 3, (For saints row 4 it is all ok, i learnt to mod it in a video on youtube) in particular i want to mod the texture of default female diffuse, but when i go to test my modification, the game will not load.
    It is all cool whenever i repack my .dds file with the tool SR3 texture utilities, (in fact my file size is 1,00 MB just like the original one) but when i have to update the asm_pc file is an hell for me. I do not get it in these tutorials:
    Saints Row The Third Modding Basics
    Editing Character Textures for Lazy Louts, and the Technically Inept(like me!)

    maybe i do not get it because i am stupid, i do not know an help would be appreciated, thanks in advice.
     
  2. I recommend updating the asm_pc files with the ASM_Updater

    Edit: Just found out how confusing it is to update asm without the ASM_Updater
    • You must create a .txt file with a program like Notepad
    • Copy over:

    Code (Text):
    Gibbed.SaintsRow3.PackSTR2.exe Default_female_diffuse.str2_pc C:\User\Default female diffuse

    Gibbed.SaintsRow3.UpdateASM.exe G:\User\customize_player.asm_pc .
    pause
    • Where I put C:\User\ is where you locate the folder named "Default female diffuse" containing files: @streams, f_ideal_d.cvbm_pc, f_ideal_d.gvbm_pc
    • Where I put G:\User\ is where you locate a untouched custominze_player.asm_pc to be updated
    • Save your .txt file as .bat
    • Run your newly made batch file
    • You will find a new Default_female_diffuse.str2_pc ready to use with your updated customized_player.asm_pc
     
    Last edited: Sep 1, 2017
  3. Ok thank you, i will try, and let you know if it works.
     
  4. I tried, the game crashes.
     
    Last edited: Aug 29, 2017
  5. Did you forget to rename default_female_diffuse_PACKED.str2_pc to default_female_diffuse.str2_pc?

    You must have missed a step somewhere, I recommend this tutorial to resolve any missed steps.
    TEXTURING 101 ( LAMENS TERMS)
     
  6. So, i copy customize_player.vpp_pc from the game in Gibbed tools folder, i drag and drop it in Gibbed.SaintsRow3.UnpackVPP.exe, open customize_player folder, cut and paste the two files (the asm_pc and str2_pc) in gibbed tools folder. Now i take Default female diffuse.str2_pc, drag and drop it in Gibbed.SaintsRow3.UnpackSTR2.exe, open the created folder, copy the files in it, then use scanti's texture tool. After that i repack it, replace the files copied before, drag and drop the folder female default diffuse in Gibbed.SaintsRow3.PackSTR2.exe , rename it like original one (deleted at this step) and do what you told me to do. Yes the date and the hour change, but when i try to play the game and load my savedata, it stops on loading screen.
     
  7. Before Repacking Default female diffuse folder with PackSTR2, you must remove/delete f_ideal_d.tga (DDS) from the folder. You should only have three files before packing:
    • @streams
    • f_ideal_d.cvbm_pc
    • f_ideal_d.gvbm_pc
    Did you do this?

    Edit: f_ideal_d.cvbm_pc and f_ideal_d.gvbm_pc date modified should be the same.
     
  8. Yes, i deleted it.
    I do some tries with sr4 too.

    Edit: I tested my skin in sr4 and it worked fine, (image resolution is 4096 x 2048 pixel, DXT1, RGB no alpha, no mipmaps, 2d texture) like the last time i did. But for this game i use ThomasJepp.SaintsRow-rev131.
    For sr3 i just changed image resolution in 2048 x 1024, but it doesn't work.
    I did lots of tests and i find out, that a reskin for the player can't work correctly without these files: Female Asian.str2_pc; Female Black.str2_pc; Female Hispanic.str2_pc; Female White.str2_pc.
    It's confirmed, the problem is in customize_player.asm_pc file, maybe i need to enable execute administrator Gibbed.SaintsRow3.UpdateASM.exe

    Edit again: Finally did it. I installed ASM updater and it works fine. Thank you very much!
     
    Last edited: Aug 31, 2017
  9. I almost gave up :oops:, glad to help.